Send Clover and LCOV coverage reports to the Coveralls service, in Dart. https://docs.belin.io/coveralls.dart
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 

5.0 KiB

Changelog

Version 5.9.0

  • Replaced the build system based on Grinder by PowerShell scripts.
  • Updated the package dependencies.

Version 5.8.0

  • Updated the documentation.
  • Updated the package dependencies.

Version 5.7.0

  • Raised the Dart SDK constraint.
  • Updated the package dependencies.

Version 5.6.0

  • Added support for branch coverage when using LCOV reports.

Version 5.5.0

  • Added support for GitHub Actions.
  • Added the Configuration.merge() method.
  • Added the Job.flagName property.
  • Updated the package dependencies.

Version 5.4.0

  • Raised the Dart SDK constraint.
  • Updated the package dependencies.

Version 5.3.0

  • Raised the Dart SDK constraint.
  • Updated the package dependencies.

Version 5.2.0

  • Raised the Dart SDK constraint.
  • Updated the package dependencies.
  • Updated the URL of the default API endpoint.

Version 5.1.0

  • Updated the package dependencies.
  • Updated the URL of the Git repository.

Version 5.0.0

  • Raised the Dart SDK constraint.
  • Updated the package dependencies.

Version 4.3.0

  • Improved the handling of SSH-based Git remotes.
  • Updated the package dependencies.

Version 4.2.0

  • Updated the package dependencies.

Version 4.1.0

  • Updated the package dependencies.

Version 4.0.0

  • Breaking change: the Configuration.fromEnvironment() constructor is now an asynchronous static method.
  • Using deferred loading for the services.
  • Updated the package dependencies.

Version 3.2.0

  • Added the Options class, used by the command line interface.
  • Raised the Dart SDK constraint.
  • Updated the package dependencies.

Version 3.1.0

  • Added a user guide based on MkDocs.
  • Added an example code.
  • Raised the Dart SDK constraint.
  • Updated the package dependencies.

Version 3.0.0

  • Breaking change: starting to use and support the Dart 2 SDK.
  • Using optional const and new.
  • Updated the package dependencies.

Version 2.1.0

  • Updated the package dependencies.

Version 2.0.1

  • Fixed a bug: the CLI script doesn’t run when using the pub global run command.

Version 2.0.0

  • Breaking change: changed the signature of most class constructors.
  • Breaking change: most class properties are now final.
  • Raised the required Dart version.
  • Breaking change: replaced the -f|--file named argument of the CLI script by an anonymous argument (e.g. coveralls lcov.info instead of coveralls -f lcov.info)
  • Breaking change: the version property is now private.
  • Added support for Clover reports.
  • Changed licensing for the MIT License.
  • Replaced the which module by where.
  • Updated the package dependencies.

Version 1.0.0

  • First stable release.

Version 0.3.0

  • Updated the package dependencies.

Version 0.2.0

  • Updated the package dependencies.

Version 0.1.1

  • Updated the documentation.

Version 0.1.0

  • Initial release.