Gulp plug-in minifying PHP source code by removing comments and whitespace. https://docs.belin.io/gulp-php-minify
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 

10 KiB

Changelog

Version 11.0.0

  • Breaking change: raised the required Node.js version.
  • Dropped support for GitHub Packages.
  • Updated the documentation.
  • Updated the package dependencies.

Version 10.3.0

  • Using private class fields.
  • Updated the package dependencies.

Version 10.2.0

  • Updated the package dependencies.

Version 10.1.0

  • Due to strong user demand, restored the TypeScript source code.
  • Fixed the issue #15: replaced the usage of the __dirname variable by import.meta.url.
  • Raised the Node.js constraint.
  • Renamed the FastTransformer.defaultAdress static property to address.
  • Replaced the JSDoc documentation generator by TypeDoc.

Version 10.0.0

Version 9.3.0

  • Modified the package layout.
  • Updated the package dependencies.

Version 9.2.0

  • Added the binary and mode properties to the Minifier class.
  • Updated the package dependencies.

Version 9.1.1

  • Fixed the issue #8: unable to spawn a custom PHP executable.

Version 9.1.0

  • Fixed the issue #10: the Gulp task does not complete.
  • Fixed the issue #12: the documentation is not up to date.
  • Updated the package dependencies.

Version 9.0.0

  • Breaking change: ported the source code to TypeScript.
  • Breaking change: removed the Minifier.factory() method.
  • Breaking change: reshaped the Transformer abstract class into an interface.
  • Ported the unit tests to classes with experimental decorators.
  • Replaced the ESDoc documentation generator by TypeDoc.
  • Replaced the ESLint static analyzer by TSLint.
  • Updated the package dependencies.

Version 8.0.0

  • Breaking change: raised the required Node.js version.
  • Breaking change: raised the required PHP version.
  • Added a user guide based on MkDocs.
  • Using PHP 7.1 features, like void functions.
  • Using the global URL class.
  • Updated the build system to Gulp version 4.
  • Updated the package dependencies.

Version 7.1.1

  • Fixed the issue #6: a required dependency was declared in the wrong section of the package.json file.

Version 7.1.0

  • Added the TransformMode enumeration.
  • Updated the package dependencies.

Version 7.0.1

  • Fixed a bug with relative file paths.

Version 7.0.0

  • Breaking change: changed the signature of most class constructors.
  • Breaking change: raised the required Node.js version.
  • Breaking change: removed the binary and mode properties from the Minifier class.
  • Breaking change: renamed the FastTransformer.DEFAULT_ADDRESS constant to defaultAddress.
  • Added new unit tests.
  • Added the Transformer abstract class.
  • Updated the package dependencies.

Version 6.0.0

Version 5.1.0

  • Replaced the SuperAgent HTTP client by node-fetch.
  • Updated the package dependencies.

Version 5.0.0

  • Breaking change: changed the factory() function to the Minifier.factory() method.
  • Updated the package dependencies.

Version 4.2.0

  • Replaced the which module by an Observable-based one.
  • Updated the package dependencies.

Version 4.1.0

  • Removed the dependency on Babel compiler.
  • Updated the package dependencies.

Version 4.0.0

  • Breaking change: restored the Observable APIs.
  • Updated the package dependencies.

Version 3.1.1

  • Fixed a code generation bug.
  • Updated the package dependencies.

Version 3.1.0

Version 3.0.0

  • Breaking change: changed the signature of the Minifier constructor.
  • Added new unit tests.
  • Updated the package dependencies.

Version 2.0.0

  • Breaking change: dropped the dependency on Observables.
  • Breaking change: raised the required Node.js version.
  • Breaking change: raised the required PHP version.
  • Breaking change: using ES2017 features, like async/await functions.
  • Added a mode option allowing to select the underlying transformer.
  • Improved the build system.
  • Ported the unit test assertions from TDD to BDD.
  • Restored the legacy transformer from version 0.2.0.
  • Updated the package dependencies.

Version 1.1.0

  • Properly handle the stream events: added support for the error event, remove the registered listeners on stream close.
  • Replaced the Codacy code coverage service by the Coveralls one.
  • Updated the package dependencies.

Version 1.0.1

Version 1.0.0

  • Breaking change: the plug-in is not anymore a default export. The use of destructuring assignment is advised to access it.
  • Breaking change: ported the CommonJS modules to ES2015 format.
  • Breaking change: ported the Promise-based APIs to Observables.
  • Breaking change: raised the required Node.js version.
  • Breaking change: replaced the test classes by plain tests.
  • Added the listening property.
  • Added a build task for fixing the coding standards issues.
  • Replaced the JSDoc documentation generator by ESDoc.
  • Replaced the JSHint linter by ESLint.
  • Updated the package dependencies.

Version 0.3.1

  • Added support for code coverage.
  • Added support for Travis CI continuous integration.

Version 0.3.0

  • Breaking change: raised the required Node.js version.
  • Added the silent option: conditionally displaying the path of the minified scripts to the standard output.
  • Drastically improved the performance (up to a 30x factor).
  • Updated the package dependencies.

Version 0.2.0

  • Breaking change: renamed the PHPMinifier class to Minifier.
  • Breaking change: raised the required Node.js version.
  • Breaking change: using ES2015 features, like default parameters and destructuring assignment.
  • Turned the package into a scoped one.

Version 0.1.2

  • Added support for Codacy code analyzer.
  • Renamed the project according to its npm package name.
  • Updated the package dependencies.

Version 0.1.1

  • Fixed some bugs.
  • Updated the package dependencies.

Version 0.1.0

  • Initial release.