Provides Node.js interoperability for Dart applications. https://dev.belin.io/nodejs-interop.dart
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
Cédric Belin bfb29dc4a5 Updated the `util` module 2 days ago
.vscode Added VSCode editor settings 1 month ago
doc Added new error codes 2 days ago
lib Updated the `util` module 2 days ago
test Added new error codes 2 days ago
tool Updated the `assert` module 1 week ago
var Initial commit 1 year ago
.editorconfig Updated the build system 3 months ago
.gitattributes Starting to use and support the Dart 2 SDK 9 months ago
.gitignore Updated the project settings 3 weeks ago
.travis.yml Disabled the container-based builds 1 week ago
AUTHORS.txt Added the legal files 1 year ago
CHANGELOG.md Updated the `errors` module 1 week ago
LICENSE.md Replaced the plain license by a Markdown one 10 months ago
README.md Updated the documentation 1 week ago
analysis_options.yaml Splitted the `nodejs_interop` library in two modules: `js` and `nodejs` 4 days ago
dart_test.yaml Updated the project settings 3 weeks ago
mkdocs.yml Disabled the edit link 3 weeks ago
pubspec.yaml Updated the process module 1 week ago

README.md

Node.js Interop for Dart

Runtime Release License Coverage Build

Node.js interoperability for Dart applications.

Documentation

Development

Requirements

If you plan to play with the sources, you will also need the latest Grinder version.

Unit tests

In order to run the tests, you must install the Node.js test dependencies by running the following command:

$ npm install

Then, you can launch the test runner from the command prompt:

$ pub run test

License

Node.js Interop for Dart is distributed under the MIT License.